XMPP issues


#1

Since I upgraded to Stretch, I’ve not been able to log in to XMPP. Pidgin says “Service unavailable”

It appears to be an issue with connecting to dovecot

/var/log/prosody/prosody.err contains lines like these:

Jan 14 21:04:25 auth_dovecot error Dovecot connection failure: error connecting to dovecot UNIX socket at ‘/var/run/dovecot/auth-client’. error was ‘luasocket was not compiled with UNIX sockets support’
Jan 14 21:04:25 modulemanager error Error initializing module ‘auth_dovecot’ on ‘rpg.phillipsuk.org’: /usr/lib/prosody/modules/mod_auth_dovecot.lua:44: Could not create a new SASL object
stack traceback:
/usr/lib/prosody/core/modulemanager.lua:29: in function </usr/lib/prosody/core/modulemanager.lua:29>
[C]: in function ‘assert’
/usr/lib/prosody/modules/mod_auth_dovecot.lua:44: in main chunk
(tail call): ?
[C]: in function ‘xpcall’
/usr/lib/prosody/core/modulemanager.lua:29: in function ‘pcall’
/usr/lib/prosody/core/modulemanager.lua:171: in function ‘do_load_module’
/usr/lib/prosody/core/modulemanager.lua:249: in function ‘load’
/usr/lib/prosody/core/usermanager.lua:67: in function ‘?’
/usr/lib/prosody/util/events.lua:67: in function ‘fire_event’
/usr/lib/prosody/core/hostmanager.lua:98: in function ‘activate’
/usr/lib/prosody/core/hostmanager.lua:44: in function ‘?’
/usr/lib/prosody/util/events.lua:67: in function ‘fire_event’
/usr/bin/prosody:337: in function ‘prepare_to_start’
/usr/bin/prosody:403: in main chunk
[C]: ?

Does anybody have any idea how I can fix this?


#2

Fwiw, I don’t use and haven’t knowingly enabled the service but exactly the same error appeared - one for each site - on Aug 07 23:13:45

Fast & loose Googling lands here:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=852250

https://hg.prosody.im/prosody-modules/rev/e9ca7fd4ad06
/usr/lib/prosody/modules/sasl_dovecot.lib.lua

… but this looks like one for support.


#3

Thanks. The Debian bug looks relevant (not sure why I didn’t find it), but I think you’re right, I’m going to have to contact support.


#4

I seem to have the same problem after an upgrade to Stretch . I’ve contacted support as there is no obvious fix.