Webmail broken after update to stretch


#1

Hi all,

I tried to update my symbiosis server to stretch and now my webmail is broken (404).
Reading some of the other posts here it looks like I should never have tried to do this, and in fact symbiosis is pretty well dead. So what gives? Should Itry to migrate away from symbiosi?


#2

I think squirrelmail isn’t deployed on new installs but vaguely remember it persisting post-upgrade. Roundcube should be supported and survived the upgrade here. Running php7 may cause some problems (stretch’s php7.0 & roundcube 1.2.3 are well out of date) but it still works well, mostly.

Imo, there were more reasons to upgrade than not.

Yup, that certainly looks the case, e.g., Letsencrypt (ACMEv1) stops working for new sites in November.

Sounds wise. At least be ready.


#3

Thanks for the reply @alphacabbage1

After some fiddling around, substituting ‘squirrelmail’ for ‘webmail’ in the URL now seems to do the trick, although I could swear that it wasn’t working this morning :confused:

All this was meant to be a step on the way to buster, but I guess that’s going to be a bridge too far for symbiosis …


#4

If you want to stick with a symbiosis-like system, then there’s https://sympl.host/ (which supports both latest stretch and buster)