Unexpected Wordpress error adding new plugins/themes


#1

I am perplexed with an issue on two sites I host which are using Wordpress. Yesterday I set about exploring a new theme and clicked the option to add a new theme and gained an error on screen.

I tried the same with a plugin and again got an error.

I switched to the other Wordpress site on a different domain and have the same issues.

The Wordpress error is remarkably obtuse.

“An unexpected error occurred. Something may be wrong with WordPress.org or this server’s configuration…”

I’ve done all the Google and support forum searches that I can think of. A number of solutions are offered but none seem to be relevant to or work for me.

I wondering if anyone else has experienced something like this and found a solution. I have Symbiosis with Jessie and an upgrade to php7.1 using dotdeb repositories.

I can add new themes/plugins manually via FTP - it just the built in options within Wordpress that seem not be functioning.


#2

Hi @agsteele

I would suspect folder permissions for themes & plugins.

However I have not checked this, but it would be my first point of call.

Regards


#3

That was my first thought. I even went as far as setting to 777 but with no change… :frowning:

I also tried changing ownership from the admin user to www-data - again no change.


#4

Just inspected a Wordpress site that I operate, symbiosis stretch server, PHP 7.2;

both folders 775
Owner/Group www-data www-data

Have checked the ability to change to another theme and install plugins from within admin panel, all functioning OK.

Hope it helps, may still be the problem.

Regards


#5

Thanks for the help. I tried those very permissions and ownership without any resolution. It may be that I need to get on and move to Stretch to get a solution.


#6

If you’re on pre-Stretch symbiosis outgoing connections made by apache are firewalled. You can temporarily move the file /etc/symbiosis/firewall/outgoing.d/50-reject-www-data and see if that works (assuming permissions are correct).


#7

Thanks @fenglish That was the exact answer needed :slight_smile:

In case anyone else comes along seeking this answer - I added api.wordpress.org to 50-reject-www-data and all is working again.


#8

In Sym stretch the behaviour has changed to allow outgoing connections by default I believe :slight_smile:


#9

That might work for api.wordpress.org but for other updates (plugins, Joomla! updates etc.) I’ve found some of the sites you need to connect to have multiple IP addresses. Same for PayPal payment notification callbacks. I had about 70 IP addresses in 50-reject-www-data at one point. Now with Symbiosis stretch that file has vanished, as the value of the restrictions it imposes is not worth the inconvenience.
So if you keep getting similar problems, just delete that file.