Symbiosis firewall logs / traccar


#1

I’ve setup traccar on my server and devices send locations through port 5055.

some seem to get caught in the firewall… can anyone point me in the direction of where the logs for the firewall are?


#2

Symbiosis firewall doesn’t log. It might be possible to configure it to do so, but I’m not sure off the top of my head how one could do that. A clue though: /etc/symbiosis/firewall… just does IPtables configuration. And custom rules can be created to log certain traffic.

But, it’s probably easier, if you’re trying to fix a bug, to use trial and error to remove suspected rules until the traccar works.

Could help more if you describe the setup more precisely. Are you expecting inbound traffic on port 5055, or is that traffic outbound to port 5055 on a different server? If outbound, is it perhaps the www-data user making the connection - there’s a rule that prevents that, I think.


#3

Hi

I’m expecting inbound on 5055.
replied to ticket


#4

Not sure if you’re familiar with traccar but when I used it last it will accept all information sent to it - but you have to add/confirm the device within traccar.

I had to check the traccar logs which confirmed the data coming in, then there’s an ID/reference you need from that data to tell traccar to insert/process the data.

I don’t think symbiosis explicity blocks that port, and if some is getting through I would say it’s working and it’s possibly a traccar config issue.

Unless you’re running traccar in docker - the symbiosis firewall doesn’t play well with docker as it removes some of dockers rules.


#5

Re. Docker, Symbiosis & Firewall.

The issue is of course not Synbiosis specific, but with any host that mixes Docker and native services that need the firewall config tweaking.

There are many workarounds and script based solutions, only one of which worked well for me.

Either tell docker to leave the firewall alone and configure it manually; let Docker control it and ignore the rest of the host’s services; or the one method that worked for me was to use Shorewall firewall, which ‘knows’ about docker.

This does mean that if using Symbiosis, you would need to configure the firewall ‘differently’.


#6

yes that’s right… .but the data wasn’t even reaching the log.
Not that familiar with traccar - yet… starting to find my way around it today though.
I think the issue was with the traccar client and it seemed to resolve by turning the client off and on again.
Not using docker


#7

The thing about traccar is that it processes the output of different devices according to the port they connect to.
This means that you may need to open a range of ports in the firewall, and try each of them to get it to correctly interpret the messages from a specific type of device.
However, if you start by sending to a known port, you can often extract the messages from the traccar log, even though Traccar can’t make sense of them. Then go to the traccar website to discover which sort of device it is, which in turn tells you which is the correct port to use.
If you are using the Traccar Client app on Android, it alway uses port 5055 but it is a little odd. It may not always send the same ID if you reinstall it.
The traccar logs are pretty detailed by default. In fact they are a bit hard to suppress!