How can I avoid outgoing mail being marked as spam?


#1

The mail sent from our domain is regularly (say 1 time in 4) marked as spam. We score 10/10 on www.mail-tester.com and the mail is un-spammy: normally to single recipients, never bulk mails. Sometimes we’re caught in spam-filters that we’ve passed fine before. It happens to a range of recipients including @gmail and @hotmail. Can you offer any advice as to how I can reduce this?


#2

Hi @u003f, are you on a symbiosis cloud server, if so have you followed all the instructions for setting up SPF & DKIM & DMARC records for your domain(s).

I have a number of cloud servers hosting a wide range of domains without any sending problems, one in particular sends out regular emails to users & new registrations, emails require account verification and always succeed so must be being received by the users.

Regards

Peter


#3

Yes to symbiosis cloud. The SPF, DKIM and DMARC records work fine, as we score 10/10 on mail-tester. Hence my surprise at our non-spam mail (e.g. replying to messages sent to us) being marked as spam. Any other suggestions?


#4

You may solve the issue by setting up SPF, DKIM & DMARC on the root server hostname. You know, the u003f.default.u003f.uk0.bigv.io server.

We did this to resolve the problem for our outgoing emails.

Also I suggest setting up SSL on the root server hostname as well.

Regards

Peter


#5

Could the reverse DNS for a domain affect the email delivery if it’s and the related info not be setup correctly?


#6

Yes, absolutely. All email authentication begins with the sending IP address. It’s the only thing the recipient can trust. Most mail servers will insist that the IP address has at least one PTR record. And at least one of those must point to a domain that has an A record pointing back to the IP address.