Gentoo GRUB trouble


#1

I gather that Gentoo systems aren’t very popular here, but as I use them in production at work and rather like them I thought I’d replace my legacy Debian VM with one. However, I’m blocked by the fact that /dev/vda seems to be inaccessible within the chroot during installation. This means that GRUB can’t be installed.

There’s a thread here on the Gentoo forums relating to this problem:

https://forums.gentoo.org/viewtopic-t-1059734.html

Does anyone have any suggestions (other than “use another distro” ;-)?


#2

Is this the chroot in our network boot environment? If so, I’d recommend running something like:

# Assuming vda2 is your root partition, and vda1 is your boot partition
mount /dev/vda2 /target
mount /dev/vda1 /target/boot
for i in proc sys dev ; do mount -o bind /$i /target/$i ; done
chroot /target

That should give you access to the proper /dev where /dev/vda exists.


#3

Thanks for your reply.
Unfortunately that didn’t help. I’ve also tried mounting all those in the manner described in the thread on the Gentoo forums and /dev/vda is inaccessible within the chroot whatever I do.


#4

If you’re booting a live CD then check that the virtio drivers are being loaded.

If you’re using the bytemark netboot environment then I’d expect those drives to already be loaded


#5

Thanks for your reply.
The live DVD is indeed loading various virtio drivers including virtio_blk.


#6

I tried again and was able to gain access to /dev/vda after booting to the netboot environment and chrooting from there rather than from within the Gentoo environment. Thanks for your assistance.