DKIM permission denied


#21

In my experience, they will contact you if they consider that your usage is above average. This is what happened us. They then charge you based on the number of email addresses you are supporting. I’ve continued to pay because I think they are very worthy of support.


#22

Ah, thanks. (I wonder how they got in touch). I’m surprised they use number of addresses as a metric.

I imagine I’ve been well under the usage limits so I’ve never had to think about it, until now. :wink: Yes, they’re awesome. I’m fairly sure I donated but that was a while back.


#23

I’ve set it to admin:admin rw-r----- for now, I see no reason why world should have read access

I’ve just had a similar problem. The “permission denied” log entry showed UID=104 and GID=106, belonging to Debian-exim, which is still unable to read the file with the above settings. I changed it to
admin:Debian-exim rw-r-----
and DKIM is working now.
I think the Symbiosis documentation should have mentioned this!


#24

It appears I first posted on this forum in 2005, and last posted in 2012. So that’s going back a bit!

I’ve recently created by first cloud VM, and am using Symbiosis - finally moving away from ‘legacy’ Bytemark server.

Anyway, I too got the same ‘exim can’t read DKIM key’ error in the exim logs after creating the key according for Symbiosis docs. Exim runs as ‘Debian-exim:Debian-exim’, so that’s the user/group that needs to be able to read it.

Like anahata, I fixed it by setting the key file to:
admin:Debian-exim rw-r-----

While writing, the Symbiosis docs for the openssl command to create the key don’t work in Stretch - needs fiddling around in the man page so find the correct equivalent command. But that’s for another form topic.