Debian Stretch on legacy VM


#1

I’m wondering if anyone has experience upgrading a legacy VM to Debian Stretch? I’ve had various issues with systemd and I’m not sure how to solve the current issue.

Most of the issues have been around PrivateTmp - searching online only suggests an issue with /tmp or /var/tmp being a symlink but that’s not the case for my servers. I’ve only solved the issues by setting PrivateTmp to false (in, for example, /lib/systemd/system/apache2.service).

My current issue is with installing mysql-server. Having simply done ‘sudo apt-get install mysql-server’, the installation can’t finish:

Job for mariadb.service failed because the control process exited with error code.
See “systemctl status mariadb.service” and “journalctl -xe” for details.
mariadb.service couldn’t start.

sudo systemctl status mariadb.service
● mariadb.service - MariaDB database server
Loaded: loaded (/lib/systemd/system/mariadb.service; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Thu 2017-10-19 14:25:37 BST; 5s ago
Process: 19809 ExecStartPre=/usr/bin/install -m 755 -o mysql -g root -d /var/run/mysqld (code=exited, status=226/NAMESPACE)

This looks the same error as I’ve previously seen but /lib/systemd/system/mariadb.service already has PrivateTmp=false

A clean install of Stretch on a local VM obviously works fine but I can’t see any obvious differences, apart from the kernel version - the VM is using Linux xxxx.vm.bytemark.co.uk 3.4.113-kvm-i386-20170815 #1 SMP Tue Aug 15 15:05:24 UTC 2017 i686 GNU/Linux whereas a new install is Linux debian 4.9.0-4-686 #1 SMP Debian 4.9.51-1 (2017-09-28) i686 GNU/Linux. Could this be the problem?

Thanks for any help,


#2

I suspect yes. systemd does rely upon the kernel being “modern enough” to support things. There are a couple of experimental kernels you can choose for the legacy virtual machine platform, which might allow a little more progress.