Can't update Jessie


#1

Every time I try and update my server the update crashes out with a symbiosis error that clears from the screen before I get a chance to read it. Also there’s nothing in the syslog to say what happened.

So in an attempt to re-install symbiosis I now see the following error message:

root@SERVER:/srv# apt-get install --install-recommends bytemark-symbiosis
Reading package lists... Done
Building dependency tree
Reading state information... Done
bytemark-symbiosis is already the newest version.
The following packages were automatically installed and are no longer required:
libjasper1 libuuid-perl linux-image-3.16.0-4-amd64 linux-image-3.16.0-5-amd64 linux-image-3.16.0-6-amd64
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
2 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] Y
Setting up symbiosis-httpd (2015:1113) ...
apache2_invoke headers: already enabled
apache2_invoke rewrite: already enabled
apache2_invoke cgi: already enabled
apache2_invoke ssl: already enabled
apache2_invoke vhost_bytemark: already enabled
/srv/WEBSITE1 owned by a system group (GID less than 1000)
/srv/WEBSITE2 owned by a system group (GID less than 1000)
/srv/WEBSITE2 owned by a system group (GID less than 1000)
/srv/WEBSITE3 owned by a system group (GID less than 1000)
/srv/WEBSITE4 owned by a system group (GID less than 1000)
/srv/WEBSITE5 owned by a system user (UID less than 1000)
/srv/WEBSITE6 owned by a system group (GID less than 1000)
/usr/lib/ruby/vendor_ruby/symbiosis/domains.rb:122:in `all': undefined method `RuntimeError' for Symbiosis::Domains:Class (NoMethodError)
from /usr/sbin/symbiosis-httpd-configure:243:in `<main>'
dpkg: error processing package symbiosis-httpd (--configure):
subprocess installed post-installation script returned error exit status 1
Setting up symbiosis-xmpp (2015:1027) ...
I: Adding XMPP client firewall rule...
I: Adding XMPP server firewall rule...
/srv/WEBSITE1 owned by a system group (GID less than 1000)
/srv/WEBSITE2 owned by a system group (GID less than 1000)
/srv/WEBSITE2 owned by a system group (GID less than 1000)
/srv/WEBSITE3 owned by a system group (GID less than 1000)
/srv/WEBSITE4 owned by a system group (GID less than 1000)
/srv/WEBSITE5 owned by a system user (UID less than 1000)
/srv/WEBSITE6 owned by a system group (GID less than 1000)
/usr/lib/ruby/vendor_ruby/symbiosis/domains.rb:122:in `all': undefined method `RuntimeError' for Symbiosis::Domains:Class (NoMethodError)
from /usr/lib/ruby/vendor_ruby/symbiosis/domains.rb:14:in `each'
from /usr/sbin/symbiosis-xmpp-configure:161:in `<main>'
dpkg: error processing package symbiosis-xmpp (--configure):
subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
symbiosis-httpd
symbiosis-xmpp
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@SERVER:/srv#

Any ideas?


#2

Change ownership of the website directories back to admin and try again?


#3

Hi @fenglish,
Thanks for the ownership note. I just realised that website5 was actually set to root:admin, rather than admin:www-data. I’ve tried setting admin:www-data and USER:www-data and both give me the same following result:

root@SERVER:/srv# apt-get install --install-recommends bytemark-symbiosis
Reading package lists... Done
Building dependency tree
Reading state information... Done
bytemark-symbiosis is already the newest version.
The following packages were automatically installed and are no longer required:
libjasper1 libuuid-perl linux-image-3.16.0-4-amd64 linux-image-3.16.0-5-amd64 linux-image-3.16.0-6-amd64
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
2 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] Y
Setting up symbiosis-httpd (2015:1113) ...
apache2_invoke headers: already enabled
apache2_invoke rewrite: already enabled
apache2_invoke cgi: already enabled
apache2_invoke ssl: already enabled
apache2_invoke vhost_bytemark: already enabled
/srv/WEBSITE1 owned by a system group (GID less than 1000)
/srv/WEBSITE2 owned by a system group (GID less than 1000)
/srv/WEBSITE3 owned by a system group (GID less than 1000)
/srv/WEBSITE4 owned by a system group (GID less than 1000)
/srv/WEBSITE5 owned by a system group (GID less than 1000)
/srv/WEBSITE6 owned by a system group (GID less than 1000)
/srv/WEBSITE7 owned by a system group (GID less than 1000)
/usr/lib/ruby/vendor_ruby/symbiosis/domains.rb:122:in `all': undefined method `RuntimeError' for Symbiosis::Domains:Class (NoMethodError)
from /usr/sbin/symbiosis-httpd-configure:243:in `<main>'
dpkg: error processing package symbiosis-httpd (--configure):
subprocess installed post-installation script returned error exit status 1
Setting up symbiosis-xmpp (2015:1027) ...
I: Adding XMPP client firewall rule...
I: Adding XMPP server firewall rule...
/srv/WEBSITE1 owned by a system group (GID less than 1000)
/srv/WEBSITE2 owned by a system group (GID less than 1000)
/srv/WEBSITE3 owned by a system group (GID less than 1000)
/srv/WEBSITE4 owned by a system group (GID less than 1000)
/srv/WEBSITE5 owned by a system group (GID less than 1000)
/srv/WEBSITE6 owned by a system group (GID less than 1000)
/srv/WEBSITE7 owned by a system group (GID less than 1000)
/usr/lib/ruby/vendor_ruby/symbiosis/domains.rb:122:in `all': undefined method `RuntimeError' for Symbiosis::Domains:Class (NoMethodError)
from /usr/lib/ruby/vendor_ruby/symbiosis/domains.rb:14:in `each'
from /usr/sbin/symbiosis-xmpp-configure:161:in `<main>'
dpkg: error processing package symbiosis-xmpp (--configure):
subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
symbiosis-httpd
symbiosis-xmpp
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@SERVER:/srv#

Kind Regards
Simon


#4

sudo chown -R admin:admin /srv
That ought to fix it.


#5

Yep, that did it