Bytemark website fails to display when I use Google to find it


#1

Hi,

When I search for “bytemark” on Google or any variations, and click on the top search results in Firefox, I get this error consistently:

Corrupted Content Error
The site at https://www.bytemark.co.uk/cloud-hosting/ has experienced a network protocol violation that cannot be repaired.
The page you are trying to view cannot be shown because an error in the data transmission was detected.
Please contact the web site owners to inform them of this problem.

This seems to apply to any URL starting with https://www.bytemark.co.uk/.

I thought this would be your servers, but to my surprise, when I visit the same URLs directly by pasting them into the URL bar in Firefox, they work. It is only the links from Google search results which are not working for me in Firefox (version 67, on a Mac).

Even stranger, if I reload in a tab with this error, the page fails and shows the same error. If I copy the URL from the URL bar, open a new tab, and paste into that tab’s URL bar, the site works! Yet the old tab still won’t load.

In case it helps, this message appears in Firefox’s console when clicking these links from Google (and no entry appears in the network tab of the devtools):

Failed to load ‘https://www.bytemark.co.uk/’. A ServiceWorker passed a promise to FetchEvent.respondWith() that rejected with ‘TypeError: NetworkError when attempting to fetch resource.’.

It’s not a problem for me, but I thought someone might like to know - and I’m curious why! Pasting a URL into a URL bar should have the same behaviour in all tabs, I would have thought. I don’t think I’ve ever seen this on another site.


#2

Hi,

I can’t replicate this problem with 66.0.3 (64-bit) on MacOS 10.14.4 (18E226)

So perhaps there’s a Firefox bug. Or maybe you have a plugin that’s messing it up?


#3

https://www.google.com/search?q=bytemark&oq=bytemark gives me as the first result:
https://www.bytemark.co.uk/
which, of course, works perfectly.
Please search google again, and instead of clicking the link, copy that link url and paste it into a reply here, so we can see what your browser is trying to reach.


#4

Common issue with Mac:

https://www.google.com/search?client=firefox-b-d&q=mac+not+displan+certain+websites


#5

Common issue with Mac

That refers to Safari, not Mac in general. The problem I’ve just reported is with Firefox.


#6

Please search google again, and instead of clicking the link, copy that link url and paste it into a reply here, so we can see what your browser is trying to reach.

That was a good idea. I think you’re expecting it to be some mangled Google tracking URL - I thought the same.

But here is the result of “Copy Link Location”, from the context menu from the blue link of the first result from www.google.co.uk, which I’ve just done right now as you asked:

https://www.bytemark.co.uk/

Clicking on the same blue link just done right now, produced:

Corrupted Content Error …

Of course copying the link and pasting it into a new tab worked perfectly, just as the original report described. That’s the point of this curious report, it’s very unusual.


#7

I’ve done more digging.

The same problem occurs when searching with Bing and DuckDuckGo - it’s not the search engine.

Traced it to the service worker at https://www.bytemark.co.uk/serviceWorker.js

When the page reached from a search engine won’t load, shows “Corrupted Content Error…”, and the reload button doesn’t fix it:

If I open another tab and go to about:debugging#workers, scroll down to the service worker whose URLs is https://www.bytemark.co.uk/serviceWorker.js, and then click “unregister” on that worker, clicking on the search result works, or if it’s already on the “Corrupted Content Error…” page, reload starts working.

Update:

It’s an interaction between ByteMark’s ServiceWorker and EFF’s Privacy Badger add-on (which blocks third party trackers), because when PB is disabled, cross-site links to the Bytemark main site works again.

The underlying cause may be Firefox bugs in ServiceWorker handling (#1499523, #1503072), which might be fixed soon.